Help with .fbx import/export (3ds max)

Xenoverse 2 Mods Forums Xenoverse Help Help with .fbx import/export (3ds max)

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #2353
    Val E RyonVal E Ryon
    Keymaster

    Hello community,

    I’d like to request a helping hand with something.

    I’m familiar with 3ds max and I modded other games like Morrowind, Skyrim, Cities: Skylines and Mount and Blade in the past.
    I’d say I’m pretty much still an amateur though, all the stuff I know about it is more or less self educated.
    With Xenoverse however I’m confronted with .fbx files for the first time.
    I watched many tutorials on that topic, lawlaw’s video has been the most helpfull until now.

    But here comes my problem: loading .fbx into 3ds max screws up the scaling. Everything I import back into Xenoverse is ridiculously oversized.
    lawlaw’s solution to this was to make sure the scale factor on both the import and export is set to 1, but 3ds max has the scale factor disabled for me. my theory is that it has something to do with my copy of 3ds max, I’m using the 2013 version.
    Furthermore, since I tried to manualy alter the unit conversion to solve the scale issue 3ds max does not import the skin modifier, and also crashes when I try to delete a surface (everything worked fine before).
    I remember running into that issue with .obj files in the past and somehow fixed it, but I can’t remember how and was not able to figure it out yet.
    I tried to do it with blender, but that thing really confuses me, I have no idea what I’m doing there most of the time.

    I contacted someone on the old forum, asked for help on the same issue, but he took a break a while ago and isn’t back yet. I knew that, but I kinda derped. It might be rude to open a thread directly after contacting him, but there is no way to know when he’ll be back. If you’re reading this: I’m sorry.

    Hmm. While I have the opportunity: thanks to everyone who is doing tutorials, ID lists, external programming of modding tools and all those awesome mods. Without you Xenoverse would be a lot less enjoyable!

    Regards,

    Val

    #2367
    Val E RyonVal E Ryon
    Keymaster

    Well. I downloaded 3ds max 2015 and read a few guides from autodesk about how 3ds max is handling .fbx files, I figured out a way to convert it the way I want it. It’s working now, so nevermind. ^^

    #2381
    zakilj3
    Member

    I have the same size problem but with blender so how did you fix this with 3ds max maybe that can help me with blender

    #2425
    Val E RyonVal E Ryon
    Keymaster

    I run into the same issues with blender, as I said, still haven#t figured that thing out yet. In 3ds max you get a FBX import screen when you… well… import an .fbx. Although the important thing everyone points out, to make sure the Scale Factor is set to 1, is unavailable to me it still scales right when I select automatic scaling on import and manually set scale to metres on export.
    In blender I do not have this option, working on it atm though.

    #2484
    Val E RyonVal E Ryon
    Keymaster

    I have the same size problem but with blender so how did you fix this with 3ds max maybe that can help me with blender

    I figured out what my problem with the conversion in blender was. Gonna leave it here, in case it could help you.

    When you export your .fbx take a look on the menu on the bottom left. Beneath the option “Scale” which should be set to 1 is a ckeckbox, “Apply Unit”. If it is checked, uncheck it. It was checked for me by default, since I had no idea what it does I never changed it. tried it out now, everything has the size and position it is supposed to have.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.